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          Preface
 
          Power electronic systems are widely used today to provide power processing for applications ranging from computing and communications to medical electronics, appliance control, transportation, and high-power transmission. The associated power levels range from milliwatts to megawatts.
 
          Modeling and simulation are essential ingredients of the analysis and design process in power electronics. They help a design engineer gain an increased understanding of circuit operation. With this knowledge the designer can, for a given set of specifications, choose a topology, select appropriate circuit component types and values, estimate circuit performance, and complete the design by ensuring that the circuit performance will meet specifications even with the anticipated variations in operating conditions and circuit component values. Power electronic systems are nonlinear variable structure systems. They involve passive components such as resistors, capacitors, and inductors, semiconductor switches such as thyristors and MOSFETs, and circuits for control. The analysis and design of such systems present significant challenges. Fortunately, increased availability of powerful computer and simulation programs makes the analysis/design process much easier.
 
          PSIM® is an electronic circuit simulation software package, designed specifically for use in power electronics and motor drive simulations but can be used to simulate any electronic circuit. With fast simulation speed and user-friendly interface, PSIM provides a powerful simulation environment to meet the user simulation and development needs.
 
          This book shows how to simulate the power electronic converter circuits in PSIM environment. The prerequisite for this book is a first course on power electronics. This book is composed of eight chapters.
 
          Chapter 1 is an introduction to PSIM. This chapter introduces the different parts of PSIM environment.
 
          Chapter 2 shows the fundamentals of circuit simulation with PSIM. You will learn how to draw the circuit schematic, connect the components together, run the simulation, measure what you want, and many other important tasks in this chapter.
 
          Chapter 3 introduces Simview™. Simview is PSIM’s waveform display and post-­processing program. This chapter studies the most important measurements that can be done with Simview.
 
          Chapter 4 introduces the most commonly used components of PSIM.
 
          Chapter 5 shows how PSIM can be used for analysis of power electronic circuits. Many examples are studied in this chapter. The studied examples are selected among the most fundamental circuits of power electronics. All the details are shown, so you can follow the examples easily.
 
          Chapter 6 shows how you can simulate motors and mechanical loads in PSIM.
 
          Chapter 7 introduces SimCoupler™. SimCoupler fuses PSIM with Simulink® by providing an interface for co-simulation. With the aid of SimCoupler, you have access to all of the Simulink blocks in your simulation.
 
          Chapter 8 introduces the SmartCtrl®. SmartCtrl is a controller design software specifically geared toward power electronic applications. It features a user-friendly interface, a simple workflow, and a comprehensible display of control loop stability and performance. SmartCtrl facilitates the simple and fast designing of controllers for various power converters. In this chapter, the controller design process is shown for a buck converter.
 
          We want to acknowledge the Powersim Inc. for providing access to PSIM during the writing of this book. We hope that this book will be useful to readers, and we welcome comments on the book. Enjoy the world of PSIM!
 
           
            Farzin Asadi
 
            Kei Eguchi

          
 
         
      
       
         
          Chapter 1 An overview of PSIM®
 
        
 
         
          
            1.1 Introduction
 
            This chapter introduces PSIM, different parts of PSIM environment, and its help system.
 
           
          
            1.2 PSIM software
 
            PSIM, which is developed by Powersim Inc. (https://powersimtech.com/), is an electronic circuit simulation software package, designed specifically for use in power electronics and motor drive simulations but can be used to simulate any electronic circuit. With fast simulation speed and user-friendly interface, PSIM provides a powerful simulation environment to meet the user simulation and development needs. PSIM is used by industries for research and product development and it is used by educational institutions for research and teaching.
 
            PSIM includes the basic package as well as the following add-on modules (modules, extended PSIM functionality into specific areas of circuit simulation, and design):
 
            Motor drive: Built-in electric machine models and mechanical load models for motor drive system studies.
 
            Digital control: Discrete library elements such as zero-order hold, z-domain transfer function blocks, quantization blocks, and digital filters for digital control system analysis.
 
            Thermal: Library elements and functions calculate semiconductor device losses and inductor losses.
 
            Renewable energy: Library elements, such as solar module, wind turbine, battery, and ultracapacitor models for renewable energy applications.
 
            Power Supply Design Suite: Pre-built design templates for resonant LLC converters.
 
            EMI Design Suite: Design templates for EMI analysis and EMI filter design.
 
            Motor control design suite: Pre-built templates for induction motor and linear/nonlinear PMSM drives.
 
            Hybrid electric vehicle design suite: Pre-built templates for hybrid electric vehicle powertrain system design.
 
            SimCoupler: Interface between PSIM and MATLAB/Simulink for co-simulation.
 
            SPICE: Functions to link to LTspice.
 
            MagCoupler: Interface between PSIM and the electromagnetic field analysis ­software JMAG for co-simulation.
 
            MagCoupler-RT: Link between PSIM and JMAG-RT data files.
 
            ModCoupler: Interface between PSIM and ModelSim for co-simulation. There are two versions of the interface: ModCoupler-VHDL that supports VHDL code, and ModCoupler-­Verilog that supports Verilog code.
 
            SimCoder: Function for automatic code generation.
 
            F2833x Target: Library elements for automatic code generation for TI F2833x series DSP.
 
            F2803x Target: Library elements for automatic code generation for TI F2803x series DSP.
 
            F2802x Target: Library elements for automatic code generation for TI F2802x series DSP.
 
            F2806x Target: Library elements for automatic code generation for TI F2806x series DSP.
 
            F2837x Target: Library elements for automatic code generation for TI F2837x series DSP.
 
            F28004x Target: Library elements for automatic code generation for TI F28004x series DSP.
 
            PE-Expert4 Target: Library elements for automatic code generation for Myway PE-Expert4 hardware platform.
 
            Processor in the loop: Interface between PSIM and TI DSP hardware boards for processor-in-the-loop simulation. It also includes the function block to support TI’s InstaSPIN® motor control algorithm.
 
            In addition, PSIM integrates the DSIM® engine into its simulation environment. DSIM is known for its incredible speed and accuracy in solving very large power converter systems, and for solving detailed switching transients. DSIM shares the same schematic capture and waveform processing environment as PSIM.
 
            Also, PSIM links with the software SmartCtrl® for control loop design. SmartCtrl is designed specifically for power converter applications.
 
            PSIM also provides the function to export the power stage to Typhoon® HIL’s real-time simulator for hardware-in-the-loop (HIL) simulation.
 
            With these product lineups, Powersim provides a complete platform from design to simulation, to hardware implementation. The overall environment is shown in ­Fig. 1.1.
 
            
              [image: ]
             
           
          
            1.3 Licensing
 
            Powersim provides four types of license for users: FREE DEMO, 30-DAY TRIAL, PSIM STANDARD, and PSIM PROFESSIONAL. Students and educational institutes can get a discount.
 
            The free demo version of PSIM can be downloaded form Products section of https://powersimtech.com/ website (Fig. 1.2).
 
            
              [image: ]
             
            The demo version does not expire but is limited in component count and allowed circuit complexity. When you use the demo version, you cannot have a waveform with more than 6,000 points in the Simview environment (Fig. 1.3). Simview is a tool for analyzing the obtained waveform.
 
            
              [image: ]
             
           
          
            1.4 PSIM environment
 
            In this section, we will take a look at different parts of PSIM. PSIM environment ­(Fig. 1.4) is composed of four parts: Menu bar, Library Browser window, commonly used components, and schematic capture.
 
            
              [image: ]
             
            Like any other Windows® program, PSIM’s menu bar (Fig. 1.5) is composed of some menus and some shortcut icons that act as an interface between the user and PSIM. These menus and their shortcut icons will be studied in the forthcoming chapters of this book.
 
            
              [image: ]
             
            PSIM has many components. The components are categorized into different groups under the Elements menu (Fig. 1.6).
 
            
              [image: ]
             
            For instance, assume that you want to add a MOSFET to your schematic using the Elements menu. In order to do this, you need to open the Elements menu, then open the Power, then open the Switches and finally click the MOSFET (Fig. 1.7).
 
            
              [image: ]
             
            Library browser (Fig. 1.8), is a search tool for components. It is the easiest way to add a component to your schematic. For instance, if you type MOSFET in the Find box and press the Enter key, then all the related components will appear in the list (Fig. 1.9).
 
            Now click on the component that you want and the component will be selected. After selecting the component, click on the schematic and the selected component will be added to it.
 
            
              [image: ]
             
            
              [image: ]
             
            If you cannot see the Library Browser window, then click on the Library Browser icon (Fig. 1.10) in order to activate the Library Browser window. You can use the View> Library Browser as another way to activate the Library Browser window (Fig. 1.11).
 
            
              [image: ]
             
            
              [image: ]
             
            Some of the most commonly used components are added to the bottom of the screen (Fig. 1.12). You can click on the desired component and add it to schematic with one click.
 
            
              [image: ]
             
            When the mouse pointer is put on a component, its name is shown in the left bottom side (Fig. 1.13).
 
            
              [image: ]
             
            PSIM shows the simulation progress with a progress bar (Fig. 1.14).
 
            
              [image: ]
             
            If your simulation has an error, then PSIM informs you using the Simulation Message window (Fig. 1.15).
 
            
              [image: ]
             
            You can see the use the View menu to open/close a window (Fig. 1.16).
 
            
              [image: ]
             
           
          
            1.5 Version of PSIM and installed modules
 
            You can see the version of PSIM and installed modules with the aid of Help> About (Figs. 1.17 and 1.18).
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            1.6 PSIM’s help menu
 
            PSIM has a powerful help system. You can see the PSIM User Manual in the Help> Documents section (Fig. 1.19).
 
            
              [image: ]
             
            The Tutorial (Fig. 1.20) and Video Tutorial (Fig. 1.21) sections contain many useful documents and videos.
 
            
              [image: ]
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            PSIM has many ready-to-use examples. Click the Open Examples from File menu in order to see these examples (Fig. 1.22).
 
            
              [image: ]
             
            After clicking the Open Examples, the window shown in Fig. 1.23 appears. Now you can open the folders and there are plenty of inspiring simulations there. For instance, if you want to see simulation related to rectifiers, you need to open the ac–dc folder.
 
            
              [image: ]
             
            You can use the File> Search Examples (Fig. 1.24) in order to search in the examples.
 
            
              [image: ]
             
            After clicking the Search Examples, enter the desired search term in the Find box (Fig. 1.25).
 
            
              [image: ]
             
            When you double click on any component placed on schematic, you can see the Help button for that component (Fig. 1.26). If you click the Help button, the help file for that component is shown.
 
            
              [image: ]
             
           
        
 
      
       
         
          Chapter 2 Basics of PSIM
 
        
 
         
          
            2.1 Introduction
 
            In this chapter, you will learn the fundamentals of circuit simulation with PSIM. You will learn how to draw the circuit schematic, connect the components together, run the simulation, and measure the circuit voltages, current, and power. Important tasks such as enable/disable a block, addition of text to schematic, exporting the drawn schematic, Free Run Mode, Simulation Control block, and AC/DC ammeter/voltmeter blocks are studied in this chapter, as well.
 
           
          
            2.2 Analysis of a simple resistive circuit
 
            Consider a simple resistive circuit like Fig. 2.1. The voltage across resistor R2 must be . 1090+10×100=10 VWe want to analyze this simple circuit with the aid of PSIM.
 
            
              [image: ]
             
            First of all, we need to make a new file. In order to do this, click the new file icon (Fig. 2.2).
 
            
              [image: ]
             
            After clicking the new file icon, the PSIM opens a new file for you (Fig. 2.3). You can draw the schematic in this file.
 
            
              [image: ]
             
            Select a DC source from Elements>Sources>Voltage>DC (Fig. 2.4).
 
            
              [image: ]
             
            You can use the Library Browser in order to select the DC source. To do this, enter the “dc source” in the Library Browser text box and press the Enter key. As shown in Fig. 2.5, a list of related blocks will be shown. Now you can select the desired one from the shown list.
 
            When you select the DC voltage source block, your mouse pointer will be changed into a DC voltage source in order to show that the DC voltage source block is selected (Fig. 2.6).
 
            
              [image: ]
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            If you press the mouse right button, then the block will be rotated in clockwise direction. If you press the mouse left button, then the block will be added to the ­schematic (Fig. 2.7).
 
            
              [image: ]
             
            After placing the DC voltage source to the schematic, press the Esc key on the keyboard or click the Select icon (Fig. 2.8). Otherwise, in each click on the schematic, a DC voltage source will be placed there. If you want to remove a block from the schematic, left click on it and press the Delete key on the keyboard.
 
            
              [image: ]
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            Add two resistors to the schematic (Fig. 2.9).
 
            The resistor block can be found in the Elements>Power>RLC Branches>Resistor (Fig. 2.10). You can search for “Resistor” in the Library Browser search box as well (Fig. 2.11). The third method for selecting the resistor block is to press the R key of your keyboard.
 
            
              [image: ]
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            Click one of the resistors in order to select it (Fig. 2.12). The PSIM draws a rectangle around the resistor in order to show that it is selected. Click the Rotation icon (Fig. 2.13) in order to rotate it (Fig. 2.14).
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            If you want to flip a block, you need to use the Flip vertical and Flip horizontal icons.
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            Use the wire tool (Fig. 2.17) in order to draw the circuit wires. You can click on its icon or you can simply press the W key on your keyboard. After wire tool is activated, the mouse cursor will be changed into a pencil. Use this pencil in order to connect the terminals of blocks together (Fig. 2.18).
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            Your circuits must have a ground. Click the ground icon (or press the G key on your keyboard) to activate the ground block (Fig. 2.19). Place the ground block in the schematic (Fig. 2.20) and use the wire tool in order to connect it to the negative terminal of the DC voltage source (Fig. 2.21).
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            If you open the Elements>Sources, you can see that PSIM has three ground blocks: Ground, Ground (1), and Ground (2) (Fig. 2.22).
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            The symbols for these blocks are shown in Fig. 2.23.
 
            
              [image: ]
             
            Although they have different appearance, all of them are the same thing from PSIM point of view (they are electrically connected together). In order to understand this matter, consider the circuit shown in Fig. 2.24. This circuit is equivalent to the one shown in Fig. 2.25 and the current drawn from the source is 5 A. The different shapes of these grounds provide the convenience for user to separate the grounding in different functional sections of the circuits.
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            We need a voltage probe in order to measure the voltage across the resistor. PSIM has two voltage probes. One of them has two terminals (Fig. 2.26) and the other one has only one terminal (Fig. 2.27).
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            You can connect each terminal of two-terminal voltage probe (Fig. 2.26) to the desired node of the circuit. With the aid of this block, you can measure the voltage difference between any two nodes of your circuit. Note that one of the terminals has a small dot behind it (Fig. 2.28). The voltage probe measures the .Vterminal with dot−Vterminal without dot
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            The voltage probe with only one terminal (Fig. 2.27) measures the voltage with respect to the ground.
 
            Add a two-terminal voltage probe to the schematic (Fig. 2.28) and connect it to the resistor (Fig. 2.29).
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            You can use a single-terminal voltage probe as well (Fig. 2.29), because one of the resistor terminals is grounded. Reading of both probes in Figs. 2.29 and 2.30 are the same.
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            Now the schematic is ready. It is time to set the components values. Double click the DC voltage source. The window shown in Fig. 2.31 appears. Enter 100 in the Amplitude box. The default value for this box is 100 so there is no need to enter it. The Amplitude box determines the voltage of the source. If the internal impedance of your source is RL type (Fig. 2.32), you can enter the values for series resistor and inductor in the “Series Resistance” and “Series Inductance” boxes, respectively.
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            If you click the Help button in Fig. 2.31, the window shown in Fig. 2.33 will appear. It is highly recommended to read the help page of the blocks. They contain many valuable and important information about the blocks.
 
            Double click the resistor blocks and enter their resistances. The default value for Model Level is “Level 1.” Do not change that property. When you check the display box (see Fig. 2.34), PSIM show the corresponding property in the schematic environment. For instance, in Fig. 2.35, the display box behind the Name and Resistance boxes are checked. So, PSIM shows the name of component (R2) and its value (10) on the schematic (Fig. 2.36).
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            Double click the voltage probe block and enter the VR2 in the Name box (Fig. 2.37).
 
            You can use the View>Fit to Page (Fig. 2.38) in order to automatically fit the schematic into the page (Fig. 2.39). You can zoom in/out with the combination of Ctrl key on your keyboard and middle mouse button. Another way is using the + and – keys on the keyboard. The zoom level of your schematic is shown in the bottom left corner of the screen (Fig. 2.40).
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            2.3 Simulating the circuit
 
            You need to add a Simulation Control block to the schematic in order to simulate the circuit. The Simulation Control block can be found in the Simulate menu (Fig. 2.41). Add a Simulation Control block to the schematic (Fig. 2.42).
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            Double click the Simulation Control block. Enter 0.02 in the Total Time box. The Total Time box determines the duration of simulation. So, 0.02 means that simulate the circuit behavior for [0 s,0.02 s] interval. Instead of 0.02 you can write 20 m. The letter m in PSIM means milli, that is, 10–3, so 20 m means 20 milliseconds. If you want to simulate the circuit for 100 μs, simply enter 100 u in the Total Time box.
 
            Computers do the calculations in discrete time. The difference between the time points can be constant or variable. For instance, a fixed step solver with time step of 10 μs do the analysis at 10 μs, 20 μs, 30 μs, 40 μs, 50 μs, . . . . However, a variable step solver uses different steps for generating the output. The variable step solvers have two steps: a small step and a big step. The small step is used for transitions, that is, change in the status of switches, or narrow pulses. Figure 2.43 shows the Simulation Control block. The Solver Type is set to fixed step with 10 μs steps.
 
            Click the Run button (or press the F8 on your keyboard) (Fig. 2.44).
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            The PSIM shows the message shown in Fig. 2.45. PSIM decreases the time step automatically in order to increase accuracy. Click OK to continue.
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            After clicking the OK, the Simview window shown in Fig. 2.46 will appear. This is waveform measured by VR2 voltage probe. Double click on the VR2. The Properties window shown in Fig. 2.47 will appear.
 
            Click on the Color box in order to select the desired color for the waveform shown in Fig. 2.46. Click the Display name box (Fig. 2.48) in order to change the title of waveform (Fig. 2.49).
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            2.4 Measurement of circuit current
 
            Click on the piece of wire that connects the resistor R1 to the DC source (Fig. 2.50). Press the Delete key on your keyboard in order to remove it (Fig. 2.51).
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            Select the current probe (Fig. 2.52), add it to the schematic, and connect it to the resistor R1 and DC voltage source (Fig. 2.53).
 
            There is another way to add a current probe to the desired location without removing the wire. If you select and drop a current probe onto a wire, it will be connected automatically to the wire.
 
            
              [image: ]
             
            
              [image: ]
             
            The current probe has a terminal with a small dot behind it. Direction of the current which enters the dot is assumed to be positive.
 
            After connecting the current probe to the circuit, double click on it, and rename it to I1. Click the help button. The window shown in Fig. 2.54 will appear.
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            According to the Help file (Fig. 2.55), the current probe block uses a 1μΩ sense resistor in order to produce a very small voltage drop and measures the current using the Ohm’s law, that is, .I=VR
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            Now run the simulation. This time the window shown in Fig. 2.56 will appear and asks you to determine the output or outputs that you want to see.
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            Select I1 from the left side list by clicking on it and press the Add button to add it to the right list (Fig. 2.57). The right list is the variables that will be displayed after clicking the OK button.
 
            Click the OK button after adding the I1 to the right list. The waveform shown in Fig. 2.58 appears. As expected the current is 1 A.
 
            
              [image: ]
             
            
              [image: ]
             
           
          
            2.5 Calculation of power
 
            In this section, we want to see the waveform of power dissipated in resistor R2. The power is nothing more than the product of current and voltage. Click the Run SIMVIEW button (Fig. 2.59) in order to ask the PSIM to draw the product of current and voltage.
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            After clicking the Run SIMVIEW button, the properties window shown in Fig. 2.60 will be opened. Click the I1 from the left list. Click the down arrow in order to add it to the bottom box. Click on the “+ – × / …” button and select the * operation. * shows the multiplication operation. After clicking the *, the bottom box changes to I1*.
 
            Now select the VR2 from the left list (click on it) and click the down arrow in order to add it to the bottom box. The bottom box changes to I1*VR2 (Fig. 2.61). You can simply type the I1*VR2 expression in the bottom box instead of described procedure as well.
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            Click the Add button in order to send the I1*VR2 expression to the right list (Fig. 2.62).
 
            Click the OK button. The waveform shown in Fig. 2.63 appears. As expected, the power dissipated in resistor R2 is 10 W.
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            2.6 Voltage and current sensors
 
            Assume that you want to simulate a DC–DC converter with average current-mode control. In this case, you need a sensor to sense the current of the inductor. Result of measurement will be used in the control circuit.
 
            The voltage/current sensor block in PSIM (Fig. 2.64) measures the voltage/current and permits you to use that measurement where needed. One of the voltage sensor terminals has a small dot behind it. The voltage sensor measures the .Vterminal with dot−Vterminal without dot Similar to the voltage sensor, one of the current sensor terminals has a dot. The current that enters this terminal is assumed to be positive.
 
            According to the Help file (Fig. 2.65), the current sensor block uses a 1μΩ sense resistor in order to produce a very small voltage drop and measures the current using the Ohm’s law, that is, I=VR.
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            Assume that we want to measure the resistor R2 power. We can use a voltage sensor to measure the voltage of resistor R2, and a current sensor to measure its current. Then we can use a multiplier block (Fig. 2.66) in order to multiply these two waveforms.
 
            The schematic shown in Fig. 2.67 calculates the power waveform using the voltage/current sensor blocks. A voltage probe block (Fig. 2.68) is used to save the calculated power waveform in this figure.
 
            Settings of components used in Fig. 2.67 are shown in Figs. 2.69–2.73. The Gain property of the voltage sensor and current sensor is equal to 1. So, the measurement result will not be amplified/attenuated.
 
            Simulation result is shown in Fig. 2.74. The resistor R2 power is 10 W as expected.
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            2.7 Measurement with current flag and voltage flag
 
            Using the voltage/current probe is not the only way to measure the voltage/current of an element. You can measure the voltage/current of an element using the voltage/current flag as well.
 
            For instance, assume that we want to measure the voltage and current of resistor R2 in the schematic shown in Fig. 2.75.
 
            Double click on the resistor R2. The Current Flag and Voltage Flag boxes default values are zero (Fig. 2.76). Change them to 1 (Fig. 2.77). Note that the resistor has a small dot behind to one of the terminals. The voltage flag measures the Vterminal with dot−Vterminal without dot. The current probe measures the current through the component and assumes the current that enters the dot to be positive.
 
            As shown in Fig. 2.75, the schematic does not contain any voltage/current probe, however if we set the voltage/current flags to 1, then we are able to measure the voltage/current of components.
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            Run the simulation. After running the simulation, the properties window will appear (Fig. 2.78).
 
            Click on I(R2) and V(R2) (Fig. 2.79). Then click the Add and OK buttons, respectively (Fig. 2.80).
 
            After clicking on the OK button, the voltage/current waveforms of resistor R2 appears (Fig. 2.81).
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